Performance degradation
Incident Report for Kintone
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 18:17 PST
Investigating
We are currently investigating this issue.
Posted Nov 12, 2020 - 17:03 PST