We're seeing a delay in sending emails.
Incident Report for Kintone
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 13:17 PST
Investigating
We are currently investigating this issue.
Posted Nov 20, 2020 - 12:48 PST
This incident affected: Send Mail.